Jump to content
WnSoft Forums
orizaba

How PTE "choose" the graphics card to work with?

Recommended Posts

My laptop is from 2013 and has 2 graphics cards: INTEL HD Graphics 4600 and AMD RADEON HD8970M (4GB).

Since sometime ago, I think AMD is not working well and INTEL is not enough to run my PTE projects, so videos do not run smooth.

I think that some years ago, I could force PTE to work using AMD. Am I wrong? I should like to be sure that PTE is only using the AMD, not the INTEL.

Some ideas on this? Thanks.

Jose

Share this post


Link to post
Share on other sites

I just saw in Troubleshooting forum the topic"Poor performance under Win10 (v1803) on laptops with dual NVIDIA graphics" dated 2018/19, and I think my actual problem with my laptop with INTEL and AMD graphics is of the same kind, I mean, a very poor video performance running PTE projects.

My actual Windows 10 Pro, version 1809, was installed May 2019 over Windows 7. Not a clean installation. Despite today INTEL and AMD drivers are 100% updated, I think I started to have my video performance problems only some months ago.  Running PTE AV Studio 10 PRO v10.0.11. Is there some way to solve this situation?

 

Share this post


Link to post
Share on other sites

Jose,

PTE 9 and PTE 10 automatically choose optimal fast NVIDIA graphics on laptops with dual graphics (NVIDIA + Intel).

Regrettably AMD doesn't provide this possibility and performance of PTE depends on default settings in Windows 10 or in AMD Radeon Catalyst Control panel.

You need to switch your 3D graphics for maximum performance (in plugged mode and with battery mode).

There are two variants:

1. For certain app. But it's not optimal if you run PTE EXE shows or preview.

2. Global settings for all apps. Recommended by me.

You can also read this article, probably it will help:
https://www.trickyways.com/2019/07/how-to-force-an-app-to-use-dedicated-gpu-windows/#gpp

Share this post


Link to post
Share on other sites

Hi Igor,

I think I have a real problem. I already tried all you said and followed the article, but situation is same. I can not remember when problem started, either when I installed W10, or later with some Windows update. Another possibility is my AMD is damaged. Some other idea?

Share this post


Link to post
Share on other sites

Hi There

I earlier this evening got informed there is a new update from Nvidia to go along with the new Windows 10 update . The update from Nvidia when it starts scans your computer and tells you if your version as an update and then gives you a break down of your system .

Michael

Share this post


Link to post
Share on other sites

Problem is my graphics card is AMD, not Nvidia.

 

Share this post


Link to post
Share on other sites

AMD drivers 100% updated. Is it possible that hardware acceleration is not working?

Share this post


Link to post
Share on other sites

What model laptop? Maybe the laptop will only use AMD GPU when laptop is plugged in.  Also I would check the BIOS config and see if there is a setting to disable integrated GPU.

Also FAQ from AMD
https://www.amd.com/en/support/kb/faq/dh-017

Tom

Share this post


Link to post
Share on other sites
19 hours ago, Igor said:

Jose,

Try to update Windows 10 to the latest version v2004 (May 2020). I already installed this update:

https://support.microsoft.com/en-us/help/4028685/windows-10-get-the-update

Hi Igor,

Thank you so much, I updated W10 to v2004 (upgrade 9252.exe) as you advised. I was using v1809.

Things are better now, but not yet 100% perfect as in old days.

Using Task Manager while PTE is running, I can now see that INTEL is almost constant around 16%, while AMD is working from 35 to 43%. Before the update, INTEL and AMD were working both around 17% (as I can remember). Why is this? I should like to know an explanation. As I said, things are not yet perfect. In fact, sometimes video does not run smooth, mainly when PTE changes from one video clip to the next one (in the timeline).

I tried to use the "switchable graphics function" in the AMD settings but such function does not exist in my case. Does this mean that my laptop (CLEVO P170SM / August 2013) does not allow to switch graphics (INTEL HD Graphics 4600 and AMD Radeon HD 8970M)?

Regards,

Jose779956659_AMDRadeonHD8970M.thumb.jpg.3bd35d04d4d122e2558357e63b238ef2.jpg

Share this post


Link to post
Share on other sites
18 hours ago, tom95521 said:

What model laptop? Maybe the laptop will only use AMD GPU when laptop is plugged in.  Also I would check the BIOS config and see if there is a setting to disable integrated GPU.

Also FAQ from AMD
https://www.amd.com/en/support/kb/faq/dh-017

Tom

Hi Tom,

My laptop is CLEVO P170SM (August 2013) and I always use it plugged in (battery does not charge anymore). BIOS does not allow to disable integrated INTEL graphics. In FAQ from AMD they say to use "Switchable graphics option", but in my case that option does not show.

Things are better now, after updating Windows 10 to actual new version 2020, as Igor suggested. But situation is not yet 100% perfect as some months ago.

Thank you for your help.

Regards,

Jose

Share this post


Link to post
Share on other sites

Jose,

I'm glad that your laptop works faster with PTE now.

Do you have AMD Radeon Control panel? If yes, check again for any options to enable best performance mode for 3D apps.

Check your settings according this article: https://docs.microsoft.com/en-us/windows-hardware/customize/desktop/customize-power-slider

Also another reason of reduced performance in 3D apps - dust inside cooling system of a laptop.

Share this post


Link to post
Share on other sites

Igor,

Thanks again, yes, I followed the article and did as it is told, but things kept the same. In AMD Radeon Control Panel (now called AMD Radeon Software - Adrenalin 2020 Edition) there is no way to change performance, neither to switch graphics). As you suggest, problem could be dust inside cooling system, I will check this soon.

Best regards,

Jose

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...