Jump to content
WnSoft Forums

Recommended Posts

Me - being Hungarian - has to write vowels with different accents. I know I am in the minority, but please, can you consider my problem. When I try use my keyboard and press the ű (which is a u with two dashes above) it becomes u on the screen. Unfortunately this could cause problem in the understanding of the text. For years I keep trying to avoid vowels with dashes but sometimes it is impossible.

Do you have any ideas of avoiding this problem or could you do something in your new version?

Thank you very much Sarolta

Share this post


Link to post
Share on other sites

Hi Sarolta,

There may be a workaround for your problem. The ASCII characters (256 of them) can be accessed by first activating the numeric keypad on your keyboard then by holding down the keyboard "ALT" key and typing in the correct series of numbers on the numeric keypad you can achieve all the "accent" marks you wish to use.

For example:

http://office.microsoft.com/en-ca/excel/HA101675391033.aspx

There are also downloadable scripts for different languages I believe....

Also see:

http://windowshelp.microsoft.com/Windows/e...1d1dc41033.mspx

You can actually put in most any specialized letters by this method which will work with PTE. There are a variety of ASCII character sets - I'm not sure whether or not there is one for Hungarian, but I'll bet there is!

see:

http://stason.org/TULARC/travel/hungary-hu...acter-sets.html

and for general information:

http://knopok.net/symbol-codes/ascii-code.html

As an alternative, you can always type your text in Microsoft Word, etc., then copy and past in place of the word "text" in PTE. The accent marks will be preserved.

Best regards,

Lin

Share this post


Link to post
Share on other sites

Another option in Windows is to go to Start>All Programs>Accessories>System Tools and select Character Map. In Character Map you can select the appropriate letter, press the Select button then the Copy button which copies the letter into Windows clipboard, then paste it into PTE. Character Map also displays in the lower-right corner of its window the ALT-nnnn code that Lin mentions above. Using Character Map is somewhat clumsy, but it does work. Don't worry about which font you're using in Character Map, when you paste into PTE you'll get the character in whatever font you have active in PTE (or should, at least that's how it works in Photoshop where I use Character Map regularly for accented characters in text layers for title and credit slides).

Share this post


Link to post
Share on other sites

Thank you very much for your help, but I still can not manage my accents.

When I type/copy the text the characters look OK but by the time they appear on the screen the accents disappear. So far the best font seems to be Microsoft Sans Serif, which has all the required accented letters (o and u both small and capital with two dashes). I tried the ALT+combination as well, the same happens. Is there something else I should be doing?

Thank you very much for your advice and help

Sarolta

Share this post


Link to post
Share on other sites

Hi Sarolta,

Presumably, when you work in your word-processing software or your e-mail software you have no problems. Please confirm this is the case.

Are the fonts that you use in your word-processor available in the list of fonts in PTE's O&A window?

If so, do they behave in PTE the same as they do in your word-processor?

regards,

Peter

Share this post


Link to post
Share on other sites
Hi Sarolta,

Presumably, when you work in your word-processing software or your e-mail software you have no problems. Please confirm this is the case.

Are the fonts that you use in your word-processor available in the list of fonts in PTE's O&A window?

If so, do they behave in PTE the same as they do in your word-processor?

regards,

Peter

Yes you are right, I can write my accented vowels in word-processing , and e-mails.

The most frequently used font is Times New Roman which has all the special characters we (Hungarians) require. This is the one I use in PTE.

All the vowels with dots above the letter do work in PTE. It is only the dashes above the letters which are ignored at display.

I hope I'm explaining it clearly, if not, please, let me know.

Thanks Sarolta

I hope I'm explaining it all right,

Share this post


Link to post
Share on other sites

Hi Sarolta,

My turn to clarify understanding:

- you use Times New Roman in both word processing and in PTE

- in word-processing everything works as you want - there are no problems with any of the specially accented characters

- in PTE some accented characters are OK but others are not

Is that a correct summary of the situation that you have?

If so, it does seem to point to a problem with PTE's use of fonts.

Please confirm that I have understood correctly.

regards,

Peter

Share this post


Link to post
Share on other sites
Hi Sarolta,

My turn to clarify understanding:

- you use Times New Roman in both word processing and in PTE

- in word-processing everything works as you want - there are no problems with any of the specially accented characters

- in PTE some accented characters are OK but others are not

Is that a correct summary of the situation that you have?

If so, it does seem to point to a problem with PTE's use of fonts.

Please confirm that I have understood correctly.

regards,

Peter

Hi Peter,

Yes, you are right in everything you say.

Let me suggest an experiment to prove my point.

Have a slide ready in PTE and add a text line - say "első" this is a Hungarian word meaning "first". When you type it in to your text line it looks ok. but when you display it the accents will disappear.

Anyway, this is what is happening with me.

Thank you for helping me

Sarolta

Share this post


Link to post
Share on other sites

Hi,

My impression is that PTE only shows characters correctly that belong to the ASCII character set. Example: "ç" has the ASCII code 0231 (correctly shown in PTE), while "ű" does not have any (PTE shows "u"). Of course, both characters can be expressed in Unicode.

Regards,

Xaver

Share this post


Link to post
Share on other sites

Sari, if I understand your original post, you want some text to appear as part of a slide in PTE, but PTE isn't displaying certain characters correctly (e.g., ö if I'm reading my screen correctly).

If you are using Photoshop, I can confirm (in Photoshop CS3 and probably other recent versions) that the text tool in Photoshop does correctly display these characters. I can create a file in Photoshop and type in the word "elsö" as a text layer (using any font on my system in conjunction with Windows Character Map as mentioned in my earlier post above), save the result as a JPG, and use that as a slide in a PTE show. Unless you're wanting to animate the text (in the Objects and Animations window in PTE), I don't see any disadvantage to imbedding the text in the slide in Photoshop (or other editing software, if it has a text feature and does display these characters correctly). If you don't want the text to appear superimposed over the image, you can create an expanded canvas around the photo and imbed the text on the portion of the canvas that does not contain the image.

Don't know if this meets your needs, but check your photo-editing software and see if you can get it to display your text corrrectly. If it does, and you don't want or need to animate the text, then that's an easy work-around.

Personally I never use the text features in PTE, since I don't like animated text and don't otherwise see any need for me to use PTE text features, given that I have that option in Photoshop.

Share this post


Link to post
Share on other sites

Hi Sarolta,

It seems that only the ASCII character sets may be entered and that the cut and paste doesn't work for characters not recognized as ASCII but I believe that there are alternate ASCII character sets which can be used which have the Hungarian characters. The issue is how to install this extended set.

Please read the following:

http://en.wikipedia.org/wiki/ISO/IEC_8859-2

I've been testing with my keyboard set to Hungarian and have been able to get double accents.

I have only gotten to zero 251 with my testing, but it appears that you will be able to do what you want to do using the Numeric Keypad with keyboard "Alt" followed by the proper sequence of numbers. - see below:

Lin

Later:

Sarolta,

Using Windows XP Home Edition, I was able to go into my Control Panel and change my language to Hungarian then use the numeric keypad and get the following using respectively:

Alt zero two one three (Alt 0213), Alt zero two one nine (Alt 0219), Alt zero two four five (Alt 0245) and Alt zero two five one (Alt 0251).

test.jpg

If you test all possible combination's I'm pretty sure you will be able to do what you want to do. If you get to a point with ALT 02XX where it stops putting in characters, go to ALT 3000 and so on. I wish I could find a chart which would give the exact keystrokes for all Hungarian characters but so far I've not found one. I do believe however, than since I have been able to put the double accents on the O and U that you will find a combination to also put in your other Hungarian specific characters.

Do not try to do this in Word or other word processor but rather directly in the text in PTE. You can test and make a chart so you can easily enter any special Hungarian language character by simply using the Numeric Keypad.

Share this post


Link to post
Share on other sites

Are you able to create the text you require in Photoshop?

If so save as a transprent PNG file and use that in PTE.

Not a real solution - more of a workaround.

DaveG

Share this post


Link to post
Share on other sites
Are you able to create the text you require in Photoshop?

If so save as a transprent PNG file and use that in PTE.

Not a real solution - more of a workaround.

DaveG

Thanks Dave,

I think your idea is the simplest workaround, mind you it is a bit cumbersome for a few simple words.

Thank you very much

Sarolta

Share this post


Link to post
Share on other sites

Is this a good time to hint that it would be nice to be able enter Asian fonts as well?

The only work around now is to enter Asian fonts in Photoshop.

Bobo

Share this post


Link to post
Share on other sites

Hi Sarolta,

As you can see in my sample, it's very easy to place the double accents over the O and U by using the Numeric Keypad and typing the appropriate Alt xxxx numbers as indicated in my post.

Of course you "can" do it in Photoshop as suggested by making a PNG file or you can do it in Photoshop by adding the text to your image as well, however, I don't see either of these methods "easier" than simply typing the "ALT XXXX" characters on your Keyboard Numeric Keypad.

Does your keypad not function in the same way as mine?

Best regards,

Lin

Thanks Dave,

I think your idea is the simplest workaround, mind you it is a bit cumbersome for a few simple words.

Thank you very much

Sarolta

Share this post


Link to post
Share on other sites
Hi Sarolta,

As you can see in my sample, it's very easy to place the double accents over the O and U by using the Numeric Keypad and typing the appropriate Alt xxxx numbers as indicated in my post.

Of course you "can" do it in Photoshop as suggested by making a PNG file or you can do it in Photoshop by adding the text to your image as well, however, I don't see either of these methods "easier" than simply typing the "ALT XXXX" characters on your Keyboard Numeric Keypad.

Does your keypad not function in the same way as mine?

Best regards,

Lin

Hi Lin,

My Language is set to Hungarian, and tried the ALT+number combination on my numeric keypad- still I got the same result - i.e. the dashes do not appear on the screen. All the other accents are correct, only the dashes seem to vanish.

Thank you anyway for your patience.

Sarolta

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...